fractionToSignedPeriodicFraction Method

Convert a sweep fraction to the equivalent period-shifted fraction inside this sweep, or within one period of zero on the desired side.

fractionToSignedPeriodicFraction(fraction: number, toNegativeFraction: boolean): number

@returns period-shifted fraction. If fraction is already in [0,1], or the sweep is empty, then fraction is returned unchanged.

Parameter Type Description
fraction number fraction of the sweep.
toNegativeFraction boolean return an exterior fraction period-shifted to within one period of the start (true) or
end (false) of the sweep.

Returns - number

period-shifted fraction. If fraction is already in [0,1], or the sweep is empty, then fraction is returned unchanged.

Defined in

Last Updated: 21 November, 2024