angleToSignedPeriodicFraction Method
Return the fractionalized position of the given angle (as Angle) computed with consideration of 2PI period and with consideration of angle sweep direction (CW or CCW).
- the start angle is at fraction 0
- the end angle is at fraction 1
- interior angles are between 0 and 1
- negative fraction for angles "before" the start angle
- fraction larger than one for angles "after" the end angle
- allows period shift
angleToSignedPeriodicFraction(theta: Angle, zeroSweepDefault: number0.0): number
@returns fraction, or zeroSweepDefault
if this sweep is empty.
Parameter | Type | Description |
---|---|---|
theta | Angle | input angle |
zeroSweepDefault | number | return value when this sweep is empty (default 0) |
Returns - number
fraction, or zeroSweepDefault
if this sweep is empty.
Defined in
- geometry3d/AngleSweep.ts Line 415
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.