angleToPositivePeriodicFraction Method

Return the fractionalized position of the given angle (as Angle), computed with consideration of 2PI period.

  • the start angle is at fraction 0
  • the end angle is at fraction 1
  • interior angles are between 0 and 1
  • all exterior angles are at fractions greater than 1
  • allows period shift

angleToPositivePeriodicFraction(theta: Angle, zeroSweepDefault: number0.0): number

@returns nonnegative fraction, or zeroSweepDefault if the sweep is empty.

Parameter Type Description
theta Angle input angle
zeroSweepDefault number return value when this sweep is empty (default 0)

Returns - number

nonnegative fraction, or zeroSweepDefault if the sweep is empty.

Defined in

Last Updated: 21 November, 2024