trigValuesToHalfAngleTrigValues MethodStatic
Compute the angle A given rcos(2A) and rsin(2A) for some nonnegative scalar r.
- This function assumes the input arguments are related to an angle between -PI and PI.
- This function returns an angle between -PI and PI.
trigValuesToHalfAngleTrigValues(rCos2A: number, rSin2A: number): TrigValues
@returns cos(A), sin(A) and A in radians
Parameter | Type | Description |
---|---|---|
rCos2A | number | scaled cosine value of twice the angle A. |
rSin2A | number | scaled sine value of twice the angle A. |
Returns - TrigValues
cos(A), sin(A) and A in radians
Defined in
- geometry3d/Angle.ts Line 416
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.