orientedRadiansBetweenVectorsXYZ MethodStatic

Returns the angle between two vectors, with the vectors given as xyz components, and an up vector to resolve angle to a full 2PI range.

  • The returned angle is (-PI < radians <= PI) or (0 <= radians < 2 * PI)
  • The angle is in the plane of the U and V vectors.
  • The upVector determines a positive side of the plane but need not be strictly perpendicular to the plane.

orientedRadiansBetweenVectorsXYZ(ux: number, uy: number, uz: number, vx: number, vy: number, vz: number, upVectorX: number, upVectorY: number, upVectorZ: number, adjustToPositive: booleanfalse): number

Parameter Type Description
ux number x component of vector u
uy number y component of vector u
uz number z component of vector u
vx number x component of vector v
vy number y component of vector v
vz number z component of vector v
upVectorX number x component of vector to positive side of plane.
upVectorY number y component of vector to positive side of plane.
upVectorZ number z component of vector to positive side of plane.
adjustToPositive boolean  

Returns - number

Defined in

Last Updated: 21 November, 2024