appendCurveCollectionClip Method
Modifies the insideIntervals array given in place. Note: curve given is passed by reference and stored.
appendCurveCollectionClip(root: AlternatingCCTreeNode, curve: CurveCollection, insideIntervals: CurveLocationDetailPair[], outsideIntervals: CurveLocationDetailPair[]): void
Parameter | Type | Description |
---|---|---|
root | AlternatingCCTreeNode | |
curve | CurveCollection | |
insideIntervals | CurveLocationDetailPair[] | |
outsideIntervals | CurveLocationDetailPair[] |
Returns - void
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.