evaluateBasisFunctions Method

Evaluate the B-spline basis functions f[] at a parameter u in a knot span.

  • This method implements the Mansfield-Cox-de Boor recurrence relation.

evaluateBasisFunctions(knotIndex0: number, u: number, f: Float64Array): boolean

@returns true if and only if output array is sufficiently sized.

Parameter Type Description
knotIndex0 number index of the left knot of the span.
u number value in the knot span: knot[knotIndex0] <= u <= knot[knotIndex0 + 1].
f Float64Array preallocated output array of order basis function values.

Returns - boolean

true if and only if output array is sufficiently sized.

Defined in

Last Updated: 21 February, 2025