createUniformWrapped MethodStatic

Create knot vector with wraparound knots at start and end, and uniform knots between.

createUniformWrapped(numInterval: number, degree: number, a0: number, a1: number): KnotVector

Parameter Type Description
numInterval number the number of intervals into which to uniformly divide the active knot interval [a0,a1],
creating numInterval-1 equally spaced interior knots between a0 and a1.
This number is equal to the number of Bezier spans in the associated B-spline object.
It is not the pole count.
degree number degree of polynomial.
a0 number left knot value for active interval.
a1 number right knot value for active interval.

Returns - KnotVector

Defined in

Last Updated: 21 February, 2025