createThroughPoints MethodStatic

Greville knot algorithm: alternative to traditional c2 cubic algorithm allowing for any order, but no end conditions or periodicity.

createThroughPoints(points: IndexedXYZCollection | Point3d[], order: number): undefined | BSplineCurve3d

Parameter Type Description
points IndexedXYZCollection | Point3d[] pass-through points.
order number bspline order (1 more than degree)

Returns - undefined | BSplineCurve3d

Defined in

Last Updated: 21 November, 2024