knotToPointAnd2Derivatives Method
Evaluate the curve and two derivatives at the given parameter.
knotToPointAnd2Derivatives(u: number, result?: Plane3dByOriginAndVectors): Plane3dByOriginAndVectors
@returns the plane with origin at the curve point, vectorU as the 1st derivative, and vectorV as the 2nd derivative.
Parameter | Type | Description |
---|---|---|
u | number | parameter in the curve domain. |
result | Plane3dByOriginAndVectors | optional result. |
Returns - Plane3dByOriginAndVectors
the plane with origin at the curve point, vectorU as the 1st derivative, and vectorV as the 2nd derivative.
Defined in
- bspline/BSplineCurve.ts Line 684
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.