extendRange Method
Extend a range so it contains the range of this curve.
- This computation is based on the poles, not the curve itself, so the returned range is generally larger than the tightest possible range.
extendRange(rangeToExtend: Range3d, transform?: Transform): void
Parameter | Type | Description |
---|---|---|
rangeToExtend | Range3d | range to extend. |
transform | Transform | transform to apply to the poles as they are entered into the range. |
Returns - void
Defined in
- bspline/BSplineCurve.ts Line 852
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.