evaluatePointAndDerivativeInSpan Method
Evaluate the curve and derivative at a fractional position within a given span.
- The derivative is with respect to the span fractional parameter, not to the curve's parameter or fractional parameter.
evaluatePointAndDerivativeInSpan(spanIndex: number, spanFraction: number): Ray3d
Parameter | Type | Description |
---|---|---|
spanIndex | number | |
spanFraction | number |
Returns - Ray3d
Defined in
- bspline/BSplineCurve.ts Line 644
Last Updated: 04 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.