create MethodStatic
Create a B-spline curve with given knots.
- The poles have several variants:
- Float64Array(3 * numPoles) in blocks of [x,y,z].
- Point3d[].
- number[][], with inner dimension 3.
- Two count conditions are recognized:
- If poleArray.length + order === knotArray.length, the first and last are assumed to be the extraneous knots of classic clamping.
- If poleArray.length + order === knotArray.length + 2, the knots are in modern form.
- Visualization can be found at https://www.itwinjs.org/sandbox/SaeedTorabi/BSpline/
create(poleArray: Float64Array | number[][] | Point3d[], knotArray: Float64Array | number[], order: number): undefined | BSplineCurve3d
Parameter | Type | Description |
---|---|---|
poleArray | Float64Array | number[][] | Point3d[] | |
knotArray | Float64Array | number[] | |
order | number |
Returns - undefined | BSplineCurve3d
Defined in
- bspline/BSplineCurve.ts Line 593
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.