createPeriodicUniformKnots MethodStatic
Create a smoothly closed B-spline curve with uniform knots.
- Note that the curve does not start at the first pole.
createPeriodicUniformKnots(poles: Float64Array | Point3d[] | GrowableXYZArray, order: number): undefined | BSplineCurve3d
Parameter | Type | Description |
---|---|---|
poles | Float64Array | Point3d[] | GrowableXYZArray | |
order | number |
Returns - undefined | BSplineCurve3d
Defined in
- bspline/BSplineCurve.ts Line 507
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.