evaluateBuffersInSpan1 Method

  • Evaluate the basis functions and one derivative at spanIndex and fraction.
    • Function evaluations are stored in the preallocated this.basisBuffer; derivative evaluations in this.basisBuffer1.
  • Immediately do the summations of the basis values times the respective poles.
    • Summations are stored in the preallocated this.poleBuffer and this.poleBuffer1

evaluateBuffersInSpan1(spanIndex: number, spanFraction: number): void

Parameter Type Description
spanIndex number  
spanFraction number  

Returns - void

Defined in

Last Updated: 21 February, 2025