evaluateBasisFunctionsInSpan Method
Evaluate the order
basis functions (and optionally one or two derivatives) at a given fractional position within
indexed span.
evaluateBasisFunctionsInSpan(spanIndex: number, spanFraction: number, f: Float64Array, df?: Float64Array, ddf?: Float64Array): boolean
@returns true if and only if output arrays are sufficiently sized.
Parameter | Type | Description |
---|---|---|
spanIndex | number | |
spanFraction | number | |
f | Float64Array | |
df | Float64Array | |
ddf | Float64Array |
Returns - boolean
true if and only if output arrays are sufficiently sized.
Defined in
- bspline/BSpline1dNd.ts Line 120
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.