addKnot Method
Insert the knot and resulting pole into the instance, optionally multiple times.
addKnot(knot: number, totalMultiplicity: number): boolean
Parameter | Type | Description |
---|---|---|
knot | number | the knot to be inserted (may already exist in the KnotVector). |
totalMultiplicity | number | the total multiplicity of the knot on return. |
Returns - boolean
Defined in
- bspline/BSpline1dNd.ts Line 258
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.