setLensAngle Method
Set the lens angle for this view.
setLensAngle(angle: Angle): void
@note This does not change the view's current field-of-view. Instead, it changes the lens that will be used if the view is subsequently modified and the lens angle is used to position the eyepoint.
@note To change the field-of-view (i.e. "zoom") of a view, pass a new viewDelta to #lookAt
Parameter | Type | Description |
---|---|---|
angle | Angle | The new lens angle in radians. Must be greater than 0 and less than pi. |
Returns - void
Defined in
- core/frontend/src/ViewState.ts Line 2104
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.