forEachTileTreeRef Method
Deprecated in 5.0. Use getTileTreeRefs instead.
Execute a function against each TileTreeReference associated with this view. This may include tile trees not associated with any GeometricModelState - e.g., context reality data.
forEachTileTreeRef(func: (treeRef: TileTreeReference) => void): void
@note This method is inefficient (iteration cannot be aborted) and awkward (callback cannot be async nor return a value). Prefer to iterate using getTileTreeRefs.
Parameter | Type | Description |
---|---|---|
func | (treeRef: TileTreeReference) => void |
Returns - void
Defined in
- core/frontend/src/ViewState.ts Line 520
Last Updated: 20 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.