replaceViewedModels Method
Attempt to replace the set of models currently viewed by this viewport, if it is displaying a SpatialView
replaceViewedModels(modelIds: Id64Arg): Promise<void>
@note This function only works if the viewport is viewing a SpatialViewState, otherwise it does nothing.
@note If any of the requested models is not yet loaded this function will asynchronously load them before updating the set of displayed models.
Parameter | Type | Description |
---|---|---|
modelIds | Id64Arg | The Ids of the models to be displayed. |
Returns - Promise
Defined in
- core/frontend/src/Viewport.ts Line 972
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.