isPointVisibleXY Method
Determine whether the supplied point is visible in the viewport rectangle.
isPointVisibleXY(point: Point3d, coordSys: CoordSystemCoordSystem.World, borderPaddingFactor: number0.0): boolean
Parameter | Type | Description |
---|---|---|
point | Point3d | the point to test |
coordSys | CoordSystem | the coordinate system of the specified point |
borderPaddingFactor | number | optional border for testing with inset view rectangle. |
Returns - boolean
Defined in
- core/frontend/src/Viewport.ts Line 1776
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.