determineVisibleDepthRange Method
Computes the range of npc depth values for a region of the screen
determineVisibleDepthRange(rect?: ViewRect, result?: DepthRangeNpc): undefined | DepthRangeNpc
@returns the minimum and maximum depth values within the region, or undefined.
Parameter | Type | Description |
---|---|---|
rect | ViewRect | the rectangle to test. If undefined, test entire view |
result | DepthRangeNpc | optional DepthRangeNpc to store the result |
Returns - undefined | DepthRangeNpc
the minimum and maximum depth values within the region, or undefined.
Defined in
- core/frontend/src/Viewport.ts Line 1801
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.