addViewport Method
Add a new Viewport to the list of opened views and create an EventController for it.
addViewport(newVp: ScreenViewport): BentleyStatus
@returns SUCCESS if vp was successfully added, ERROR if it was already present.
@note raises onViewOpen event with newVp.
Parameter | Type | Description |
---|---|---|
newVp | ScreenViewport | the Viewport to add |
Returns - BentleyStatus
SUCCESS if vp was successfully added, ERROR if it was already present.
Defined in
- core/frontend/src/ViewManager.ts Line 275
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.