addDecorator Method
Add a new Decorator to display decorations into the active views.
addDecorator(decorator: Decorator): () => void
@throws Error if decorator is already active.
@returns a function that may be called to remove this decorator (in lieu of calling dropDecorator.)
@see dropDecorator
Parameter | Type | Description |
---|---|---|
decorator | Decorator | The new decorator to add. |
Returns - () => void
a function that may be called to remove this decorator (in lieu of calling dropDecorator.)
Defined in
- core/frontend/src/ViewManager.ts Line 484
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.