createDefaultView Method
Creates a default ViewState3d based on the model ids passed in. If no model ids are passed in, all 3D models in the iModel are used.
createDefaultView(options?: ViewCreator3dOptions, modelIds?: string[]): Promise<ViewState>
@throws IModelError If no 3d models are found in the iModel.
Parameter | Type | Description |
---|---|---|
options | ViewCreator3dOptions | Options for creating the view. |
modelIds | string[] | Ids of models to display in the view. |
Returns - Promise<ViewState>
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.