forEachTileTreeRef Method
For each TileTreeReference belonging to this provider that should be drawn in the specified Viewport, apply the provided function.
This method is inefficient because it does not permit the caller to prematurely halt iteration; and awkward because func
cannot be async
nor
return any value.
Implementations should implement getReferences, and callers should prefer to call getTileTreeRefs.
forEachTileTreeRef(viewport: Viewport, func: (ref: TileTreeReference) => void): void
Parameter | Type | Description |
---|---|---|
viewport | Viewport | |
func | (ref: TileTreeReference) => void |
Returns - void
Defined in
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.