connectViewportViews Function
Form a connection between two or more Viewports such that every aspect of the viewports are kept in sync. For example, if the set of models or categories visible in one viewport is changed, the same set of models and categories will be visible in the other viewports.
connectViewportViews(viewports: Iterable<Viewport, any, any>): () => void
@see - connectViewportFrusta to synchronize only the Frustum of each viewport.
- connectViewports to customize how the viewports are synchronized.
Parameter | Type | Description |
---|---|---|
viewports | Iterable<Viewport, any, any> |
Returns - () => void
Defined in
- core/frontend/src/ViewportSync.ts Line 128
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.