findExactMatch Method
Find a tool by its localized keyin.
findExactMatch(keyin: string): undefined |
@returns the Tool class, if an exact match is found, otherwise returns undefined.
@note Make sure the i18n resources are all loaded (e.g. await IModelApp.i81n.waitForAllRead()
) before calling this method.
Parameter | Type | Description |
---|---|---|
keyin | string | the localized keyin string of the Tool. |
Returns - undefined |
the Tool class, if an exact match is found, otherwise returns undefined.
Defined in
- core/frontend/src/tools/Tool.ts Line 1195
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.