ParseAndRunResult Enumeration
The result type of parseAndRun.
Members
Name | Value | Description |
---|---|---|
BadArgumentCount | The number of arguments supplied does not meet the constraints of the Tool. @see minArgs and maxArgs. |
|
FailedToRun | The tool's parseAndRun method returned false . |
|
MismatchedQuotes | An opening double-quote character was not paired with a closing double-quote character. | |
Success | The tool's parseAndRun method was invoked and returned true . |
|
ToolNotFound | No tool matching the toolId in the keyin is registered. |
Defined in
- core/frontend/src/tools/Tool.ts Line 879
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.