BeWheelEventProps Interface
Properties for constructing a BeWheelEvent
Extends
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
time | number | undefined | ||
wheelDelta | number | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
button Inherited | BeButton | undefined | BeButtonEventProps | The mouse button for this event. |
coordsFrom Inherited | CoordSource | undefined | BeButtonEventProps | How the coordinate values were generated (either from an action by the user or from a program.) |
inputSource Inherited | InputSource | undefined | BeButtonEventProps | Whether this event came from a pointing device (e.g. |
isDoubleClick Inherited | boolean | undefined | BeButtonEventProps | If true, this is the second down in a rapid double-click of the same button. |
isDown Inherited | boolean | undefined | BeButtonEventProps | If true, this event was generated from a mouse-down transition, false from a button-up transition. |
isDragging Inherited | boolean | undefined | BeButtonEventProps | If true, this event was created by pressing, holding, and then moving a mouse button. |
keyModifiers Inherited | BeModifierKeys | undefined | BeButtonEventProps | |
point Inherited | Point3d | undefined | BeButtonEventProps | The point for this event, in world coordinates. |
rawPoint Inherited | Point3d | undefined | BeButtonEventProps | The raw (unadjusted) point for this event, in world coordinates. |
viewPoint Inherited | Point3d | undefined | BeButtonEventProps | The point, in screen coordinates for this event. |
viewport Inherited | ScreenViewport | undefined | BeButtonEventProps | The ScreenViewport for the BeButtonEvent. |
Defined in
- core/frontend/src/tools/Tool.ts Line 326
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.