TileUser Namespace
Function
Name | Description |
---|---|
TileUser.generateId | |
TileUser.viewportsFromUsers | Iterate the subset of users that are Viewports. |
Defined in
TileUser Interface
Represents some object that makes use of Tiles in some way - e.g., by requesting and/or displaying their contents, querying their geometry, etc. Each Tile keeps track of its users via its TileUsageMarker. A tile with no users is eligible to be discarded view Tile.prune. Every Viewport is a tile user. It is occasionally useful to have a tile user that is not a viewport. Every TileUser is identified by an integer Id that is unique among all extant TileUsers. This Id must be obtained via generateId. Every TileUser must be registered with tileAdmin before use via registerUser and unregistered via forgetUser after it ceases using tiles.
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
discloseTileTrees Readonly | (trees: DisclosedTileTreeSet) => void | Disclose all tile trees currently in use by this user. | |
iModel Readonly | IModelConnection | The iModel with which the user is associated. | |
onRequestStateChanged Readonly | (req: TileRequest) => void | undefined | An optional function invoked when a TileRequest associated with a Tile in use by this user changes state - e.g., when the request completes, fails, or | |
tileUserId Readonly | number | A unique integer identifying this user amongst all extant users. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.