TileTreeParams Interface
Parameters used to construct a TileTree.
Properties
Name | Type | Description | |
---|---|---|---|
clipVolume | RenderClipVolume | undefined | Optional clip volume applied to all tiles in the tree. | |
contentRange | Range3d | undefined | Optional volume tightly encompassing the contents of this tile tree - used for more accurate culling. | |
expirationTime | BeDuration | undefined | Optionally specifies the amount of time before tiles belonging to this tile tree are considered eligible for disposal after disuse. | |
id | string | Uniquely identifies the tile tree in the context of the IModelConnection. | |
iModel | IModelConnection | The IModelConnection to which the tile tree belongs. | |
location | Transform | Transform from tile tree coordinates to iModel coordinates. | |
modelId | string | A 64-bit identifier for the tile tree, unique within the context of its IModelConnection. | |
priority | TileLoadPriority | Loose description of the "importance" of the tiles exposed by this tile tree, used for prioritizing requests for tile content. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.