onNoContent Method
Invoked when requestContent returns undefined
. Return true if the request can be retried, e.g., via different channel.
If so, the tile will remain marked as "not loaded" and, if re-selected for display, a new TileRequest will be enqueued for it.
Otherwise, the tile will be marked as "failed to load" and no further requests will be made for its content.
The default implementation always returns false
.
onNoContent(_request: TileRequest): boolean
Parameter | Type | Description |
---|---|---|
_request | TileRequest |
Returns - boolean
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.