TileDrawArgParams Interface
Parameters used to construct TileDrawArgs.
Properties
Name | Type | Description | |
---|---|---|---|
appearanceProvider | FeatureAppearanceProvider | undefined | Optionally customizes the view's symbology overrides for the tiles. | |
boundingRange | Range3d | undefined | If defined, a bounding range in tile tree coordinates outside of which tiles should not be selected. | |
clipVolume | RenderClipVolume | undefined | Clip volume used to clip the tiles. | |
context | SceneContext | Context for the scene into which the tiles are to be rendered. | |
hiddenLineSettings | HiddenLine.Settings | undefined | Optionally overrides the view's hidden line settings. | |
intersectionClip | ClipVector | undefined | If defined, tiles should be culled if they do not intersect this clip. | |
location | Transform | Transform to be applied when drawing the tiles. | |
now | BeTimePoint | The time at which these args were created. | |
parentsAndChildrenExclusive | boolean | True if a tile and its child tiles should not be drawn simultaneously. | |
symbologyOverrides | undefined | FeatureSymbology.Overrides | Symbology overrides to apply to the tiles. | |
tree | TileTree | The tile tree from which to obtain tiles. | |
viewFlagOverrides | Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>> | Overrides to apply to the view's ViewFlags when drawing the tiles. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.