parseToQuantityValue Method
Parse input string into quantity given the ParserSpec
parseToQuantityValue(inString: string, parserSpec: ParserSpec): QuantityParseResult
@returns QuantityParseResult object containing either the parsed value or an error value if unsuccessful.
Parameter | Type | Description |
---|---|---|
inString | string | The magnitude of the quantity. |
parserSpec | ParserSpec | The parse specification the defines the expected format of the string and the conversion to the output unit. |
Returns - QuantityParseResult
QuantityParseResult object containing either the parsed value or an error value if unsuccessful.
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.