FormatterParserSpecsProvider Interface
Interface that defines the functions required to be implemented to provide custom formatting and parsing of a custom quantity type.
Properties
Name | Type | Description | |
---|---|---|---|
createFormatterSpec | (unitSystem: UnitSystemKey) => Promise<FormatterSpec> | Async function to return FormatterSpec for a custom quantity type | |
createParserSpec | (unitSystem: UnitSystemKey) => Promise<ParserSpec> | Async function to return ParserSpec for a custom quantity type | |
quantityType | QuantityTypeArg | Custom quantity id |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.