makeIpcProxy MethodStatic
Create a type safe Proxy object to make IPC calls to a registered backend interface.
makeIpcProxy<K, C extends string>(channelName: C): PickAsyncMethods<K>
Parameter | Type | Description |
---|---|---|
channelName | C | the channel registered by the backend handler. |
Returns - PickAsyncMethods<K>
Defined in
- core/frontend/src/IpcApp.ts Line 126
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.