_generateChildIds MethodProtected
Get child IDs of a quad and generate tiles based on these child IDs.
See ImageryTileTree._loadChildren for the definition of resolveChildren
where this function is commonly called.
_generateChildIds(quadId: QuadId, resolveChildren: (childIds: QuadId[]) => void): void
Parameter | Type | Description |
---|---|---|
quadId | QuadId | quad to generate child IDs for. |
resolveChildren | (childIds: QuadId[]) => void | Function that creates tiles from child IDs. |
Returns - void
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.