TxnEntityChanges Interface
Describes a set of elements or models that were modified as part of a transaction in a BriefcaseConnection, serving as the payload for the onElementsChanged and onModelsChanged events. The inserted, deleted, and updated compressed Id sets can be awkward to work with. It can be more convenient to iterate over the individual TxnEntityChanges, especially if you with to filter out some changes.
Extends
Implemented by
Methods
Name | Description | |
---|---|---|
filter(options: TxnEntityChangesFilterOptions): TxnEntityChangeIterable | Obtain an iterator over changes meeting the criteria specified by options . |
Properties
Name | Type | Description | |
---|---|---|---|
deleted Readonly | string | undefined | The ids of entities that were deleted during the Txn. | |
inserted Readonly | string | undefined | The ids of entities that were inserted during the Txn. | |
updated Readonly | string | undefined | The ids of entities that were modified during the Txn, including any Elements for which one of their ElementAspects was changed. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.