queryRenderCompatibility MethodStatic
Obtain WebGL rendering compatibility information for the client system. This information describes whether the client meets the minimum rendering capabilities. It also describes whether the system lacks any optional capabilities that could improve quality and/or performance.
queryRenderCompatibility(): WebGLRenderCompatibilityInfo
@note As of 4.x, iTwin.js requires WebGL 2. If the client does not support WebGL 2, the status
field of the returned compatibility info will be WebGLRenderCompatibilityStatus.CannotCreateContext.
Returns - WebGLRenderCompatibilityInfo
Defined in
- core/frontend/src/IModelApp.ts Line 343
Last Updated: 22 December, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.