ElectronHostOptions Interface
Options for startup
Properties
Name | Type | Description | |
---|---|---|---|
developmentServer | boolean | undefined | use a development server rather than the "electron" protocol for loading frontend (see https://www.electronjs.org/docs/api/protocol) | |
frontendPort | number | undefined | port number for development server. | |
frontendURL | string | undefined | name of frontend url to open. | |
iconName | string | undefined | filename for the app's icon, relative to webResourcesPath | |
ipcHandlers | [] | undefined | list of IpcHandler classes to register | |
rpcInterfaces | RpcInterfaceDefinition<RpcInterface>[] | undefined | list of RPC interface definitions to register | |
webResourcesPath | string | undefined | the path to find web resources |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.