CategorySelectorProps Interface

Properties that define a CategorySelector

Extends

Properties

Name Type Description
categories Id64Array    

Inherited properties

Name Type Inherited from Description
classFullName Inherited string DefinitionElementProps The full name of the ECClass for this entity, in the form "Schema:ClassName"
code Inherited CodeProps DefinitionElementProps The Code for this element
federationGuid Inherited string | undefined DefinitionElementProps A FederationGuid assigned to this element.
id Inherited string | undefined DefinitionElementProps The Id of the entity.
isInstanceOfEntity Readonly Inherited undefined | undefined DefinitionElementProps A non-existent property used to discriminate between EntityProps and Entity.
isPrivate Inherited boolean | undefined DefinitionElementProps  
jsonProperties Inherited any | undefined DefinitionElementProps Optional json properties of this element.
model Inherited string DefinitionElementProps The Id of the Model containing this element
parent Inherited RelatedElementProps | undefined DefinitionElementProps The Parent of this element, if defined.
userLabel Inherited string | undefined DefinitionElementProps A user-assigned label for this element.

Defined in

Last Updated: 21 November, 2024