computeUVParams Method
Compute texture coordinates for a polyface.
computeUVParams(visitor: PolyfaceVisitor, localToWorld: Transform...): undefined | Point2d[]
@returns the texture coordinates, or undefined if computation failed.
Parameter | Type | Description |
---|---|---|
visitor | PolyfaceVisitor | The polyface for which to compute UV coordinates based on this texture mapping. |
localToWorld | Transform | The polyface's local-to-world transform, used for TextureMapping.Mode.ElevationDrape. |
Returns - undefined | Point2d[]
the texture coordinates, or undefined if computation failed.
Defined in
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.