OverrideModelAppearanceOptions Interface

Options for using override to override the appearance of a GeometricModel.

Extends

Properties

Name Type Description
elementId undefined | undefined    
modelId string The Id of the model whose appearance is to be overridden.  
subCategoryId undefined | undefined    

Inherited properties

Name Type Inherited from Description
appearance Inherited FeatureAppearance OverrideFeatureAppearanceOptions Specifies the aspects of the Feature's appearance to be overridden.
onConflict Inherited "extend" | "replace" | "subsume" | "skip" OverrideFeatureAppearanceOptions Specifies what to do if a FeatureAppearance has already been configured for the specified element, model, or subcategory by a previous call to override.

Defined in

Last Updated: 18 January, 2025