CatalogIModel.CreateNewContainerArgs Interface
Arguments for creating a new BlobContainer that holds (versions of) a CatalogIModel.
Properties
Name | Type | Description | |
---|---|---|---|
dbName Readonly | string | undefined | The name for the CatalogIModel database within the container. | |
iTwinId Readonly | string | supplies the iTwinId for the new container | |
localCatalogFile Readonly | string | A filename on the local computer of the "seed" CatalogIModel to be uploaded into the new container | |
manifest Readonly | CatalogIModel.Manifest | The manifest to be stored in the catalog | |
metadata Readonly | { description?: string, json?: [key: string]: any, label: string } | metadata stored with the new container | |
version Readonly | string | undefined | version for the catalog created CatalogIModel.CreateNewContainerArgs.localCatalogFile. |
Defined in
- core/common/src/CatalogIModel.ts Line 68
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.