ViewStoreError Namespace

Type alias

Name Description
ViewStoreError.Key  

Variable

Name Description
ViewStoreError.scope  

Function

Name Description
ViewStoreError.isError Determine whether an error object is a ViewStoreError
ViewStoreError.throwError Instantiate and throw a ViewStoreError

Defined in

ViewStoreError Interface

Errors thrown by the ViewStore API.

Extends

Properties

Name Type Description
viewStoreName string | undefined The name of the ViewStore that generated the error  

Inherited properties

Name Type Inherited from Description
iTwinErrorId Readonly Inherited ITwinErrorId ITwinError Uniquely identifies the kind of error.

Defined in

Last Updated: 26 April, 2025