OpenBriefcaseProps Interface

Properties for opening a local briefcase file via BriefcaseDb.open

Extends

Properties

Name Type Description
fileName Readonly string the full path to the briefcase file  
readonly Readonly boolean | undefined If true, open the briefcase readonly.  
watchForChanges Readonly boolean | undefined If true, open the briefcase readonly and monitor it for changes originating from another connection.  

Inherited properties

Name Type Inherited from Description
key Readonly Inherited string | undefined OpenDbKey  

Defined in

Last Updated: 18 January, 2025