DomainOptions Enumeration
Option to control the validation and upgrade of domain schemas in the Db
Members
Name |
Value |
Description |
CheckRecommendedUpgrades |
|
Domain schemas will be validated for any required or optional upgrades. Any errors will be reported back, and cause the application to fail opening the Db |
CheckRequiredUpgrades |
|
Domain schemas will be validated for any required upgrades. Any errors will be reported back, and cause the application to fail opening the Db |
SkipCheck |
|
Domain schemas will neither be validated nor be upgraded. Used only internally |
Upgrade |
|
Domain schemas will be upgraded if necessary. However, only compatible schema upgrades will be allowed - these are typically additions of classes, properties, and changes to custom attributes |
Defined in
Last Updated: 21 November, 2024