ChannelControlError Namespace
Type alias
Name | Description |
---|---|
ChannelControlError.Key | Keys that identify ChannelControlError s |
Variable
Name | Description |
---|---|
ChannelControlError.scope | the ITwinError scope for ChannelControlError s. |
Function
Name | Description |
---|---|
ChannelControlError.isError | Determine whether an error object is a ChannelControlError |
ChannelControlError.throwError | Instantiate and throw a ChannelControlError |
Defined in
- core/common/src/ITwinCoreErrors.ts Line 151
ChannelControlError Interface
Errors originating from the ChannelControl interface.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
channelKey Readonly | string | The channel key that caused the error. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
iTwinErrorId Readonly Inherited | ITwinErrorId | ITwinError | Uniquely identifies the kind of error. |
Defined in
- core/common/src/ITwinCoreErrors.ts Line 151
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.