ChangesetFileProps Interface
Properties of a changeset file
Extends
Properties
Name | Type | Description | |
---|---|---|---|
pathname | string | The full pathname of the local file holding this changeset. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
briefcaseId Inherited | number | ChangesetProps | The BriefcaseId of the briefcase that created this changeset |
changesType Inherited | ChangesetType | ChangesetProps | The type of changeset |
description Inherited | string | ChangesetProps | The user-supplied description of the work this changeset holds |
id Inherited | string | ChangesetProps | the ChangesetId |
index Inherited | number | ChangesetProps | The index (sequence number) from IModelHub for this changeset. |
parentId Inherited | string | ChangesetProps | the ChangeSetId of the parent changeset of this changeset |
pushDate Inherited | string | ChangesetProps | The date this changeset was uploaded to the hub |
size Inherited | number | ChangesetProps | The size, in bytes, of this changeset |
userCreated Inherited | string | ChangesetProps | The identity of the user that created this changeset |
Defined in
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.